System Health

Our system health is a real-time view of the performance of Sprout. Bookmark this page and check back if you experience any interruptions.

Subscribe to Updates

Sprout Social Loading Issue

Incident Report for Sprout Social

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 16:24 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2025 - 15:38 CDT

Investigating

Sprout is currently experiencing a loading issue impacting multiple product areas. Our engineers are investigating the root cause of the problem. Please subscribe to receive additional updates. We apologize for the inconvenience.
Posted Mar 14, 2025 - 15:23 CDT
This incident affected: Sprout Social Web Application.